1 (edited by Sky Captain 2007-07-14 12:43:43)

Topic: Can't find interface for module 'gg._3impact' w/ BlitzmaxDemo

Sorry, if this is a dumb question,
but I thought I'd have a look at Blitzmax using the demo with the last 3impact version I have (4.3.0.0), but keep getting that error message stated in the subject of this entry.

I actually started off with higher versions of _3impact.lib, but got like messages, only for the respective Framework entry. Reading this forum carefully, I found that I had to employ 2006_07_04_gg_3Impact.zip, but to no avail.

Of course, I followed the instructions carefully, and also took care to clean up before re-installing the _3impact lib with another  version.

I even installed  "Blitzmaxdemo" into  a directory called "Blitzmax"  for fear of possibly hardcoded paths.
No change.

So, what am I overlooking ?

Greetings
Sky Captain


PS: Thank you for creating this forum,in the first place. It seems quite valuable to me, even though I am still pondering whether to buy Blitzmax.

Re: Can't find interface for module 'gg._3impact' w/ BlitzmaxDemo

greetings Sky Captain smile  there may be issue here simply because you are running the demo of blitzmax which is way out of date.  in the least case you will need to rebuild the module to get it to run.  which of my 3Impact distros are you currently trying to run?  if its the 2006_07_04 version, then make sure under your blitzmax mod folder you have a folder called gg.mod and under that _3impact.mod.  if that is the case, then run the build modules command in blitzmax to try to get the module built for the blitzmax demo version.  still it may not work since the blitzmax demo is way, way out of date and i may have used functions only available in a newer version.

Re: Can't find interface for module 'gg._3impact' w/ BlitzmaxDemo

Greetings, GMan.

Thanks for your reply.

gman wrote:

greetings Sky Captain smile  ... which of my 3Impact distros are you currently trying to run?  if its the 2006_07_04 version, then make sure under your blitzmax mod folder you have a folder called gg.mod and under that _3impact.mod.

Yes, already had gathered that from the instructions. Nevertheless, I made sure to uninstall Blitzmaxdemo again, delete the complete Blitzmaxdemo - directory tree.
Then, I re-installed blitzmax and after that, installed the 3impact mod from 2006_07_04_gg_3Impact.zip, following the instructions closely.
(see below for results of using the cmd's Dir-Command.)

gman wrote:

if that is the case, then run the build modules command in blitzmax to try to get the module built for the blitzmax demo version.  still it may not work since the blitzmax demo is way, way out of date and i may have used functions only available in a newer version.

I can't seem to find a "Build modules" button or menu, only  "bmk makemods" in command line modus. Is that it ? Ok, but that yields
Build Error: failed to compile D:/Programme/BlitzMaxDemo/mod/gg.mod/_3impact.mod/3impact.cpp

I did neither remove nor reinstall 3impact, since, up to now, the only reference to 3impact was to copy those two ddl3impact*.dll to the system32 directory.

Here's the current directory structure/content

D:\Programme\BlitzMaxDemo>dir mod
Datenträger in Laufwerk D: ist B_APPL
Volumeseriennummer: 4844-1930

Verzeichnis von D:\Programme\BlitzMaxDemo\mod

16.07.2007  17:56    <DIR>          .
16.07.2007  17:56    <DIR>          ..
16.07.2007  17:55    <DIR>          brl.mod
16.07.2007  17:56    <DIR>          gg.mod
16.07.2007  17:55    <DIR>          pub.mod
               0 Datei(en)              0 Bytes
               5 Verzeichnis(se),  2.163.740.672 Bytes frei

D:\Programme\BlitzMaxDemo\mod\gg.mod>dir
Datenträger in Laufwerk D: ist B_APPL
Volumeseriennummer: 4844-1930

Verzeichnis von D:\Programme\BlitzMaxDemo\mod\gg.mod

16.07.2007  17:56    <DIR>          .
16.07.2007  17:56    <DIR>          ..
16.07.2007  18:03    <DIR>          _3impact.mod
               0 Datei(en)              0 Bytes
               3 Verzeichnis(se),  2.163.740.672 Bytes frei


I was hoping that the BMaxdemo would work with the 3impact mod, in order to be able to look more closely at  this combo....
Maybe, I'll  have to buy bmax blindly, now....

Re: Can't find interface for module 'gg._3impact' w/ BlitzmaxDemo

Alright, forget it.
I'm fed up with the darned Bmaxdemo....
.
.
.
.
.
.
.
.

Trusted to it that thousands of BMAX users can't be wrong.
Bought BMax online, and , as they say: 'T works like a charm.

Thanks for making the _3impact mod, GMan.

But, as they say: one evil thing spawns another.... wink
will probably have to buy-in again on the  current 3impact license, now.

Re: Can't find interface for module 'gg._3impact' w/ BlitzmaxDemo

sorry about not being able to get you going on the demo sad  i really wish BRL would update their demo to a more recent version.  plus i had little time lately for any extra projects.  life keeping me pretty busy right now :\

as for blitzmax, i dont think you will be disappointed.  while there are a few features id really like to see (method overloading mainly), its a very fun and extremely capable language.  i wish i could work in it all the time smile

Re: Can't find interface for module 'gg._3impact' w/ BlitzmaxDemo

Yes I second that, BMAX is a cosiderable leap forward (not, that I had a lot to say against Blitz3d which I also own and actually like  - but it is obvious, that the future lies with BMAX)

It was not really a big thing to buy BMAX "blindfolded", it would  have been just nice to be able to check it out with 3impact aforehand. But finding that even with your advice, Bmaxdemo just wouldn't budge, the decision to buy bmax rightaway was not too hard to fell. I do not have a lot of spare time and rather spend it on programming with a working version rather than tweaking an outdated  demo version to get it to do what it obviously doesn't want to do.
Thanks again and please keep up the good work, Gman!